Sony Xperia XZ3/XZ2 “Ok Google” is not working after the Android 10 update

sony_xperia_xz3

Several users have reported that a bad update has caused the Google Assistant’s Voice Match (OK Google) feature to stop working completely on the Sony Xperia XZ2 and the Xperia XZ3.

The bad update appears to be the August security patch that goes by a build number of 52.1.A.3.74. Following its rollout, users are no longer able to make use of the “OK Google” or “Hey Google” hotword to make voice commands.

I’m using Sony Xperia XZ2 Premium with all updates installed running on android 10. I noticed several months ago that my “Ok google” had stopped working and when I investigated the problem I realized that the option for “OK google” was disabled. Unfortunately, when I try and re-enable it, it flashes on for a half second and immediately turns back off and I get an error at the bottom of the screen saying “Something went wrong. Try again.”
Source

Hey google has been disabled on my phone (sony xperia ZX3) since the last android update (build number 52.1.A.3.74). Trying to enable in the google app throws up a message about driving apps. Trying to enable in maps throws up a message that i need to restart phone to turn on voice match.
Source

This is because the Voice Match feature got toggled off thereafter on its own, and trying to turn it back on throws a “Something went wrong. Try again” error.

Sony support hasn’t exactly been helpful with the issue as most users have already contacted them only to get asked to perform generic fixes like factory resetting the device to no avail.

Apart from this, users have also tried clearing the app’s data and retraining their voice model.

xz3 ok google not working

A screenshot of the error

While the reports do point towards the issue being from Sony’s side alone, the possibility of a bad update in the Google app can’t be ruled out. But again, most users have opined otherwise.

Either way, the first instances of reports of the issue date back all the way to August, and neither company has officially acknowledged the matter.

However, a mod on the Google forums has escalated the issue.

And if the issue is indeed on Google’s side, then we can hope for a fix soon, fingers crossed.

Nonetheless, it is still quite disheartening to know that users have not even able to make proper use of Google Assistant for almost 5 months.

Many have already given up after months of troubleshooting. But there’s only so much that can be done if something is completely broken.

With that being said, we will continue to track the issue for newer developments and update the article accordingly. For now, be sure to check out our Sony Xperia Android 11 update tracker.

PiunikaWeb started as purely an investigative tech journalism website with main focus on ‘breaking’ or ‘exclusive’ news. In no time, our stories got picked up by the likes of Forbes, Foxnews, Gizmodo, TechCrunch, Engadget, The Verge, MacRumors, and many others. Want to know more about us? Head here.

The post Sony Xperia XZ3/XZ2 “Ok Google” is not working after the Android 10 update appeared first on PiunikaWeb.

Post a Comment

0 Comments